Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Начало Помощь Поиск Войти Регистрация
Новости: Скачать PC-BSD: http://mirror.pcbsd.ru/

Русский форум дистрибутива PC-BSD.  |  PC-BSD  |  Новости о дистрибутиве (Модератор: sys)  |  Тема: LXDE во FreeBSD / PC-BSD 0 Пользователей и 1 Гость смотрят эту тему. « предыдущая тема следующая тема »
Страниц: [1] Печать
Автор Тема: LXDE во FreeBSD / PC-BSD  (Прочитано 6703 раз)
nomoo
Понимающий
***

Репутация: 59
Offline Offline

Пол: Мужской
Сообщений: 774


Просмотр профиля
« : Октября 08, 2010, 03:28:16 pm »

Команда разработчиков с радостью сообщила об обновлении порта легковесного оконного менеджера LXDE, который, с скором будущем, планируется включить в дистрибутив PC-BSD 9.0.

Существующий FreeBSD порт достаточно устарел и один из участников команды PC-BSD Kris обновил порт и устраненил неразрешенные зависимости. Поскольку порт был только что обновлён, команда разработчиков призывает всех желающих и заинтересованных к тестированию LXDE.

Установить порт в FreeBSD можно выполнив команду pkg_add-R LXDE-meta или используя Ports Jail в PC-BSD. Стоит также отметить, что запрос на создание PBI был недавно сформирован, и инсталлятор вскоре будет доступен пользователям.

( http://www.sys64.ru/lxde-%D0%B2%D0%BE-freebsd-pc-bsd )
Записан
infra-red
Понимающий
***

Репутация: 12
Offline Offline

Пол: Мужской
Сообщений: 239


Просмотр профиля
« Ответ #1 : Октября 10, 2010, 02:40:04 pm »

Хороший повод опробовать LXDE в действии, а то так и не видел.
Записан

Сам ничего не понимаю, но всё Вам объясню.
a1ewka-gal4onok
Редактор
Гуру
*

Репутация: 78
Offline Offline

Пол: Мужской
Сообщений: 1662



Просмотр профиля
« Ответ #2 : Марта 07, 2011, 08:39:58 am »

Решил обробовать. С установкой проблем не возникло. Лишь был "стоп" при сборке:
Код:
===>  Installing for lxpanel-0.3.7_5
===>   lxpanel-0.3.7_5 depends on file: /compat/linux/lib/libasound.so.2 - not found
===>    Verifying install for /compat/linux/lib/libasound.so.2 in /usr/ports/audio/linux-alsa-lib
===>  linux-alsa-lib-1.0.10.3_2 bsd.linux-rpm.mk test failed: default package building at OSVERSION>=800076 was changed to linux-f10 ports, please define OVERRIDE_LINUX_NONBASE_PORTS to build other linux infrastructure ports.
*** Error code 1

Stop in /usr/ports/audio/linux-alsa-lib.
*** Error code 1

Stop in /usr/ports/x11/lxpanel.
*** Error code 1

Stop in /usr/ports/x11/lxpanel.
*** Error code 1

Stop in /usr/ports/x11/lxde-meta.
[a1exei1987@pcbsd-8891] /usr/ports/x11/lxde-meta#

Исправилась ситуация добавлением в /etc/make.conf строки OVERRIDE_LINUX_NONBASE_PORTS=yes

Всё же XFCE4 мне как-то больше по душе.
Записан
Страниц: [1] Печать 
Русский форум дистрибутива PC-BSD.  |  PC-BSD  |  Новости о дистрибутиве (Модератор: sys)  |  Тема: LXDE во FreeBSD / PC-BSD « предыдущая тема следующая тема »
Перейти в:  


Войти

Powered by MySQL Powered by PHP Powered by SMF 1.1.3 | SMF © 2006, Simple Machines LLC PC-BSD